How Android Forum

Full Version: Blackberry Z10 Losing network signal
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello folks, I’m using blackberry mobile since more than one year and didn’t got this issue. Now I have noticed that once it’s network signal is lost it will not come back untill we restart my blackberry z10 after that we receiving only 2-3 signal blocks while my 3G is on sometimes its occasionally get 4 blocks that’s very strange cause this never happened on my blackberry phone.

Any tips would be fab.

Many thanks to taking time here.
I think this is due battery. Did you check another battery on your phone.
The battery may be defective or the charger is over charging the battery. If you'r using the wall charger try the data cord plugged into a PC. If you see the same problem it's the battery. If the problem goes away then replace the charger.

Thanks
(03-26-2014, 02:49 PM)Sulthan85 Wrote: [ -> ]Hello folks, I’m using blackberry mobile since more than one year and didn’t got this issue. Now I have noticed that once it’s network signal is lost it will not come back untill we restart my blackberry z10 after that we receiving only 2-3 signal blocks while my 3G is on sometimes its occasionally get 4 blocks that’s very strange cause this never happened on my blackberry phone.

Any tips would be fab.

Many thanks to taking time here.

Hi, I had faced same issue but I fixed it. So I would suggest take out the phone's battery and placing it back in. If the issue still persists, then I suggest contacting your network service provider and try a new SIM card.

Thanks