Login with your social account

Thread Rating:
  • 115 Vote(s) - 2.54 Average
  • 1
  • 2
  • 3
  • 4
  • 5

A500 frozen at android logo!
#1

Well, as of right now, the tablet cannot seem to get past the "android" text logo. The Acer logo flashes, followed by the android logo, but there it stays indefinitely. I can still turn the tablet off by holding down the power button, and powering it back on still gives haptic feedback.

The tablet is pretty much stock and brand new! I bought it on the 20th of August, and since then I've loaded only apps from the market, and I have not rooted it.

This situation started as I was reading a .pdf using the Aldiko ereader app. At first, I simply put down the tablet to do something, only to find out that it had turned itself off. I turned it back on, read a few pages, and put the tablet back down on a table. Not 2 minutes later when I picked it back up, it was already stuck on the android logo, and I've not been able to change it since then.

I've tried hitting the hard reset button with a pencil, and I've also tried simply leaving the tablet on the android splash screen for 2 hours. Nothing is working..

When I connect the tablet to the computer via usb, it does not show up as an external drive anymore as it first did when I loaded my ebooks on.

What do I do? Is the tablet salvageable? Is this a hardware issue and thus should I return it? I very much enjoy using this tablet, and got it on sale as a discontinued item, so I doubt I'll be able to exchange it unless I get supremely lucky at a costco somewhere...

Thanks for your time,
Reply
#2

When a Acer Iconia Tab A500 becomes unresponsive or when the Acer Iconia Tab A500 slows to a crawl or you can’t remember the phones password? You’re in luck! There is still a pretty powerful option available, and that is to perform a reset/ hard reset, also known as an alternate reset, on the device.

See this post : How to reset Acer Iconia Tab A500?

Hope can solve your problem.

Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)